• Technical support is temporarily provided through the Discord

US Server is Presently Borked

Rhombus

Resident Of Avalon
Founder
Joined
Mar 2, 2016
Messages
11
Likes
12
#1
It seems like a lot of players, right now, can't connect to US server.

What's being done about it?
I submitted a ticket about a related problem... I received a prompt reply...the Devs are on it!

Thank You, Yukinochi (y)
 
Last edited by a moderator:

Kaori

Wanderer
Joined
Oct 12, 2016
Messages
39
Likes
28
#2
I just logged in without any problems, haven't been in game yet today though, otherwise.
 

Rhombus

Resident Of Avalon
Founder
Joined
Mar 2, 2016
Messages
11
Likes
12
#3
I just logged in without any problems, haven't been in game yet today though, otherwise.
Yes, I don't think it was happening to everybody...I just logged in and my characters are fixed...Support is great!
 

DeadSkullzJr

Phazon Clan Leader
Gold Founder
Joined
Jul 22, 2016
Messages
194
Likes
75
#5
its happening to some users, but never fear, devs are always on the job fixing stuff ;).
 

MolliMayhem

Resident Of Avalon
Bronze Founder
Joined
Jul 31, 2015
Messages
66
Likes
80
#6
I have a character on US server, but I noticed when I was playing I seem to have a lot of, for lack of a better word, lag? Whenever I pan from side to side, my camera moves extremely quickly and blurs everything. Also happens while running. I have to stop moving and catch up with myself. I made another character on the EU server and the problem seems to be lessened, but i'm wondering if it has anything to do with the server population?

Has anyone else had this problem, and is there a fix for it in the options somewhere?
 

DeadSkullzJr

Phazon Clan Leader
Gold Founder
Joined
Jul 22, 2016
Messages
194
Likes
75
#7
Might be server population, US had the release first so we have a bit more than the other two servers.
 

Rhombus

Resident Of Avalon
Founder
Joined
Mar 2, 2016
Messages
11
Likes
12
#8
I have a character on US server, but I noticed when I was playing I seem to have a lot of, for lack of a better word, lag? Whenever I pan from side to side, my camera moves extremely quickly and blurs everything. Also happens while running. I have to stop moving and catch up with myself. I made another character on the EU server and the problem seems to be lessened, but i'm wondering if it has anything to do with the server population?

Has anyone else had this problem, and is there a fix for it in the options somewhere?


Molli...I found that in graphic settings turning Post Processing to LOW gets rid of the motion blur...Also, turn down View Distance to
LOW...And, turn down Shadows to High or Medium improves lighting in dark places, like caves.

Hope that helps.
 
Top Bottom